Synergy

Issue Tracker (powered by SPIT)

Support #3768 - failed to load shell library, synwinxt.dll is missing or invalid / XP Pro Sp3

Status:
Duplicate
Priority:
Normal
Assignee:
None
Category:
None
Created by:
Created on:
18 Oct 2013 08:28
Updated by:
Updated on:
8 Nov 2013 23:13
Google ID:
None
Redmine ID:
None

  • Duplicates: Bug #3785 - Synwinxt.dll error opening file for writing during install of 1.4.15

Steps to reproduce:

Whenever I start the service, as client or server, I get this message : 'failed to load shell library, synwinxt.dll is missing or invalid'

Versions and operating systems:

Windows XP Pro SP3 Version : 1.4.14 Other computer is on seven 64(and working).


#1

19 Oct 2013 01:31: Rick Byrne wrote a comment.

I'm having the same problem.

The new version seemed to install OK on my Windows 7 64-bit machine, but I'm getting the same error on my Windows XP SP 3 machine.

Don


#2

19 Oct 2013 04:02: Keith Esau wrote a comment.

I'm having the exact same problem, but only on my Win XP3 (x86) machine. My Win 7 machines (both x86 and 64-bit) work fine.

Keith


#3

19 Oct 2013 16:45: Andy P wrote a comment.

I'm experiencing the same problem but only on my Win XP3 (x86) machine.


21 Oct 2013 08:19: Edouard Maza changed Einzelheiten.

Added 13 character(s).


#4

21 Oct 2013 08:20: Edouard Maza wrote a comment.

Yes, it only happens on XP Sp3, it works on Seven, just clarified it.


#5

21 Oct 2013 09:51: ross o'malley wrote a comment.

Same win Xp 32 bit sp3


#6

21 Oct 2013 16:49: Philip Yang wrote a comment.

trying to connect win xp 32 as a client to win 7 64 as server. 'failed to load shell library, synwinxt.dll is missing or invalid' appears only on win xp PC. fine on win7.


#7

22 Oct 2013 16:13: Oliver Hiob wrote a comment.

Same problem here, I reinstalled 1.4.12 on the XP machine and it connected fine with 1.4.14, just a lack of desired functionality.


#8

22 Oct 2013 21:47: Tim Norman wrote a comment.

On Windows 8.1 I'm getting a Error opening file for writing when installing 1.4.14. The same copy worked just fine on my Windows 7 machine. If I hit ignore I get a "parameter is incorrect" shortly after.


#9

22 Oct 2013 22:41: Sklar Hast wrote a comment.

Ok, this is crapola pretty much. Something told me not to jump in before seeing if there were problems with the new version but I wanted drag and drop and bit before I looked. Going back to 1.4.12........I hope.


#10

28 Oct 2013 21:26: Jim Robbins wrote a comment.

I ran synergyc.exe from the command line on my Windows XP SP3 32-bit system and got the following error:

synergyc.exe - Entry Point Not Found The procedure entry point RegDeleteTreeA could not be located in the dynamic link library ADVAPI32.dll.

According to the MSDN Dev Center (http://msdn.microsoft.com/en-us/library/windows/desktop/aa379776%%28v=vs.85%%29.aspx), the RegDeleteTree function was not available until Windows Vista. Trying to use that function in the synwinxt.dll is what is causing the library to fail to load on Windows XP. You can use the SHDeleteKey function from the Shell API instead on Windows XP (and Windows 2000 if that's still supported).


#11

4 Nov 2013 14:50: Michael J. Dailey wrote a comment.

This issue is duplicated by: http://synergy-foss.org/spit/issues/details/3769/ and http://synergy-foss.org/spit/issues/details/3815/.


#12

4 Nov 2013 14:54: Michael J. Dailey wrote a comment.

Still an issue in 1.4.15, completely unusable with Windows XP SP3.


#13

5 Nov 2013 02:44: Frank Yueh wrote a comment.

Windows XP Pro SP3 Version 1.4.15 have same error


#14

5 Nov 2013 09:43: Ron Wang wrote a comment.

Same win Xp 32 bit sp3 Both server and client ,and when client , WIN7 64bit as server all have same error report.


#15

5 Nov 2013 10:57: Daniel Silion wrote a comment.

Same win XP PRO 64 bit sp2.


#16

5 Nov 2013 11:24: Simon Sunke wrote a comment.

Same with Win XP Pro 32bit with SP3


#17

5 Nov 2013 15:52: Roger Storment wrote a comment.

Same Here. Vista and XP 32 Bit


#18

5 Nov 2013 23:39: Oli Jack wrote a comment.

I also have the same problem. win Xp 32 bit SP3 // Synergy server 1.4.15


#19

6 Nov 2013 21:31: Chris Hogan wrote a comment.

Me too - clean 1.14.14 install on two XP SP3 systems


#20

6 Nov 2013 22:53: Van Warren wrote a comment.

Same problem Win XP Pro 32 bit, missing synwinxt.dll file. downgrading to 1.14.12


#21

6 Nov 2013 22:59: Van Warren wrote a comment.

works perfectly on downgrading to 1.14.12.


8 Nov 2013 23:13: Nick Bolton changed Status.

New Duplicate


#22

11 Nov 2013 03:28: Frank Yueh wrote a comment.

please fix it! :(((


#23

12 Nov 2013 20:43: Keith Esau wrote a comment.

No longer works to downgrade to 1.4.12. That version won't connect to 1.4.15.


#24

13 Nov 2013 10:09: Miguel Gómez wrote a comment.

Same issue, Synergy in WinXP Pro 32 bits:

failed to load shell library, synwinxt.dll is missing or invalid

Version 1.4.15


#25

13 Nov 2013 10:49: Ian Delemare wrote a comment.

XP Pro 32 as client Win7 Home 64 as server.... gives corrupted or missing synwinxt.dll. I installed the stable 1.3 x86 as the client and got Synergy working across my 2 PCs


#26

13 Nov 2013 20:02: Sean Adamic wrote a comment.

same issue on win 7 pro with all current updates to os


#27

16 Nov 2013 18:34: Joseph Pannoni wrote a comment.

same issue


#28

26 Nov 2013 10:58: Κωνσταντίνος Γεωργοκίτσος wrote a comment.

Same issue with Win XP SP3


#29

26 Nov 2013 17:37: Luka PacQ wrote a comment.

Same here on Win XP SP3 Media Center Edition


#30

28 Nov 2013 07:19: Сергей Поляков wrote a comment.

Same problem (( WinXP SP3


#31

30 Nov 2013 21:31: Jonathan Fashbaugh wrote a comment.

I have the same problem with version 1.4.15 creating the error:

NOTE: connecting to service... NOTE: connection established INFO: watchdog status: error NOTE: starting server NOTE: config file: C:/DOCUME~1/User/LOCALS~1/Temp/qt_temp.gq3424 NOTE: log level: INFO INFO: service command updated INFO: starting new process INFO: Synergy 1.4.15 Server on Microsoft Windows XP x86 INFO: drag and drop enabled ERROR: failed to load shell library, synwinxt.dll is missing or invalid FATAL: failed to start server: unable to open screen ERROR: failed to launch, error: process immediately stopped INFO: backing off, wait=2s, failures=1 INFO: starting new process ...

I'm running it on Windows XP SP3, attempting to connect to a 64-bit Windows 8 running the same 1.4.15 version.

I was able to get a connection with 1.3.8, although I wasn't able to swap between the two screens (this was likely user error since I haven't used 1.3.8 much).


#32

1 Dec 2013 01:24: Jonny Hotchkiss wrote a comment.

morning all. ssd died, so re-installing everything. day 4! new synergy installed, client connects then disconnects, trying to reg the dll causes the same issue reported here on the client (windows xp sp3, very old desktop, my "multi-mon" with synergy and hipponvnc and patched concurrent remote desktop service)

alas, no synergy. downgrading until solved. many thanks


#33

6 Dec 2013 18:56: Yuriy Bakhmetyev wrote a comment.

The same problem. Fix it, please!!!!!


#34

7 Dec 2013 09:39: Jérémy Demylle wrote a comment.

Same problem here on Win XP SP3 32 bit.


#35

7 Dec 2013 21:24: Neitha Schneider wrote a comment.

Same problem as well on Vista 32 bit (1.4.15), XP SP3 32 bit (1.4.12) and Win 7 SP1 64 bit (1.4.15). Worked up until the time I upgraded Vista to 1.4.15 32 bit. Same error ERROR: cannot read configuration "C:/Users/Owner/AppData/Local/Temp/qt_temp.Hp3064": read error: line 30: duplicate screen name "My-Laptop" synergys.exe: no configuration available ERROR: failed to launch, error: process immediately stopped I am going to try downgrading back to 1.4.13 and checking if that corrects it. ALSO no drag and drop since donating.


#36

12 Dec 2013 18:39: Ernesto Johnson wrote a comment.

Note: I don't think this is a real duplicate of: http://synergy-foss.org/spit/issues/details/3785/ - at least from a functional standpoint: it sounds like the issue is non-fatal in a Win7 environment, but for WinXP - the program will not function at all.


#37

16 Dec 2013 00:54: Jesse Ferrell wrote a comment.

Ditto error on XP with 1.4.15


#38

16 Dec 2013 22:18: Robbie Rai wrote a comment.

I get the same error here, have to downgrade to 1.4.12 on windows xp 32bit for it to work. Windows 7 64bit works fine on the new version.


#39

17 Dec 2013 05:42: Shawn Taylor wrote a comment.

Same issue here. Get this fixed already!


#40

22 Dec 2013 22:03: Roger Rehr wrote a comment.

Same experience here upgrading to 1.4.15 with XP SP3 environ.

Lack of fix after all this time suggests that the update channel is not ready for prime time.

Good thing that there are alternatives.


#41

28 Dec 2013 11:25: Andreas Kühne wrote a comment.

1.4.15 funktioniert auf meinen 2 PC mit XP SP3 nicht, bekomme die oben beschriebene Fehlermeldung. 1.4.12 läuft. Synergy funktioniert aber nur, wenn der Server-PC mit Adminbenutzerkonto läuft, ist das normal ?


#42

9 Feb 2014 06:23: Eric Wen wrote a comment.

winxp, same issue.

failed to load shell library, synwinxt.dll is missing or invalid


#43

9 Feb 2014 06:26: Eric Wen wrote a comment.

32bit, Winxp Pro +SP3, English, 1.4.15

If downgrade to 1.4.12, everything is ok to connect to win7.


#44

19 Feb 2014 17:12: Gene Abshire wrote a comment.

This would figure, I waited until a full software cycle had evolved until I donated, then I donate, and now I don't have what I donated for. Please get this fixed. I can't install the 15 version, I can't get it working after uninstalling and re-installing 16, please don't make me feel like more of an ass than I already feel, and get this fixed quickly. The update has effectively killed my desktop setup.


#45

20 Feb 2014 17:41: Jonas Gröger wrote a comment.

I solved this by just uninstalling Synergy and removing the directory it was installed (you might have to restart after uninstalling to delete synwinxt.dll). Then I installed the new version on my devices and it worked flawlessly.


#46

23 Feb 2014 10:11: Andrel G Linnenbank wrote a comment.

That seems to work (Vista64). I deleted the files in the directory. I could not delete synwinxt.dll until after I logged out and logged in again (faster that restarting). After that I could reinstall. So probably synwinxt.dll is not deleted during uninstall, possibly because it is not closed properly.