Important: Do not post bugs. Please read the FAQ before posting (or your question may be ignored).
4
1

Mac OSX 10.7.2 using Synergy 1.4.5 as Server Windows 7 using Synergy 1.4.5 as Client

Mouse works perfectly, but keyboard doesn't at all. Whatever I type (after clicking on a type-able space on the Windows client) goes into the last focused item on the Mac server.

Anyone else with similar issues? Thanks!

asked 05 Nov '11, 04:00

harry_boi's gravatar image

harry_boi
16112
accept rate: 0%

got the same issue (server) OSX 10.7.2 and Windows XP SP3

(21 Nov '11, 06:56) maestr0

i am having the same issue here between osx 10.7.2 (server) and Windows 7 (client) please help as i just got my mac two Days ago and am pretty bummed That this is not working.

(01 Jan '12, 19:20) manfeddy2

Yep got the same issue here. Mouse works fine but the keyboard does not

Jeremy MacMull

(04 Jan '12, 10:32) JeremyMacMull

Same issue, except OSX 10.7.1 and many versions of Synergy and a linux desktop client (Red Hate Enterprise Linux)

(04 Jan '12, 20:02) harbingerofzeke

Got the same problem here, MacOSX 10.7.2 (Lion) using Synergy 1.4.5 app as Server and Windows 7 Ultimate 64bits using Synergy 1.4.5 as client. Keyboard get crazy after trying using alt+tab, etc

(07 Jan '12, 17:16) isurfers

i can confirm that the same problem exists on 1.4.7 and that Steve G's fix works on 1.4.7. however multitouch mouse gestures still do not work including the wheel on a mighty mouse.

(05 Mar '12, 10:47) halimcho

i'm having the same problem. i've been able to get the keyboard to work, but a lot of special keys don't work at all and cause weird issues.

i have 1.4.7 running as server on mac os 10.7.3 and also 1.4.7 running as client on windows 7 x64. as you can see, the shift key doesn't work at all. other keys cause the windows machine to think that alt is constantly pressed. for example, the double-quote and underline character. none of the control, cmd, or option keys work either. when i press something like double-quote on the mac, even the physical keyboard on the windows machine stops working until i move the mouse back to the mac screen.

i tried steve's fix, but i already had that option enabled. i've also tried switching keyboard settings on the mac and windows and still can't get anything to work.

(05 Mar '12, 12:49) Osiris
showing 5 of 7 show 2 more comments

Running synergy 1.4.7 on Snow Leopard (server), synergy 1.3.7 on Fedora 16 (client). On the mac do: System Preferences > Universal Access > Enable access for assistive devices = yes Now restart synergys on the mac and keyboard input will be sent to Fedora 16 client.

This is the same fix as noted above for os x/1.38 server -- windows client. So there seems to be a bug in the os x synergy server which has persisted into the latest version.

I do want to note that with this setup it appears that extraneous keyboard input is being sent to the Fedora client. For example clicking within a window on Fedora will restore down the window from fullscreen.

link

answered 09 Apr '12, 18:17

Steve%20G's gravatar image

Steve G
1412
accept rate: 50%

edited 09 Apr '12, 18:26

This works with Synergy version 1.3.6, but no later versions.

link

answered 13 Jan '12, 14:24

bojolais's gravatar image

bojolais
412
accept rate: 0%

Running synergy 1.3.8 on Snow Leopard (server), synergy 1.3.4 on Windows 7 (client). On the mac do: System Preferences > Universal Access > Enable access for assistive devices = yes Now restart synergys on the mac and keyboard input will be sent to Windows 7 client.

link

answered 23 Jan '12, 15:36

Steve%20G's gravatar image

Steve G
1412
accept rate: 50%

I had the same problem running version 1.3.8 server on my Mac OS 10.7.2 machine and 1.3.8 client on my Windows 7 machine. After reading bojolais's answer, I replaced 1.3.8 with 1.3.6 on my Mac, and left 1.3.8 on my Windows 7 machine. The keyboard now works.

link

answered 19 Jan '12, 16:32

yacitus's gravatar image

yacitus
11
accept rate: 0%

restar synergy and try the keyboard worked for me thanks alot

link

answered 21 Jun '12, 21:14

safeco10's gravatar image

safeco10
1
accept rate: 0%

Check for any open modal boxes on the mac and dismiss them. I had this happen a couple of times and couldn't figure it out. Then I found a login dialog open in Mail. Once I dismissed that dialog it started working again.

link

answered 19 Apr '13, 15:26

leeahoward's gravatar image

leeahoward
12
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×268
×251
×244

Asked: 05 Nov '11, 04:00

Seen: 8,803 times

Last updated: 19 Apr '13, 15:26

powered by OSQA